How to prepare my site for MailPoet 3.0

MailPoet 3 is already launched and you can install it and run side-by-side with your current version of MailPoet. 

You can download it here: https://wordpress.org/plugins/mailpoet/

This new version will improve the performance, scalability and reliability of our plugin, and it will require a specific version of PHP on your website.

How do I know if my site's PHP needs to be updated?

It's really simple!

  1. Go to your website's backend.
  2. Make sure you're running MailPoet version 2.6.14 or greater. (You can check that on each MailPoet page at the bottom right corner.)
  3. If you don't have MailPoet 2.6.14, simply update your plugin to the latest version.
  4. Then go to our update dashboard page by clicking the version number in our footer, as shown in the following figure.

  5. Once you're on that page, if you need to update a big message will be here to remind you of that.

  6. Otherwise you're good to go! :)

How to proceed with the update?

We have found different guides depending on the hosting company you are using. Look for the guide corresponding to your host and follow the steps they give you.

My hosting company is not on the list, what now?

It's easy, simply send an email to your hosting company's tech support, here is a template of how you should ask this change:

Hello There!

I need to update my WordPress website to use at least PHP version 5.3. My website's server is currently running on a lower version.

Can you please update my site mysite.com, or let me know how can I do this myself.

Thank you,

Was it easy?

If you tried the steps described above but didn't manage to update your site, get in touch with us and we'll be happy to help you.